re = /(0416|0426|0412|0414|0424)[0-9]{7}/
str = '04125187034
04245098952
04262545797
04160253340
04145752260'
# Print the match result
str.match(re) do |match|
puts match.to_s
end