const regex = /(0416|0426|0412|0414|0424)[0-9]{7}/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0416|0426|0412|0414|0424)[0-9]{7}', 's')
const str = `04125187034
04245098952
04262545797
04160253340
04145752260`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}