$re = '/(0416|0426|0412|0414|0424)[0-9]{7}/s';
$str = '04125187034
04245098952
04262545797
04160253340
04145752260';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);