package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(0416|0426|0412|0414|0424)[0-9]{7}`)
var str = `04125187034
04245098952
04262545797
04160253340
04145752260`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}