import Foundation
let pattern = #".+(\r|\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 | ChatGPT | プラグイン | ソフトウェア | チャットボット、自動化 | ChatGPTは、チャットボットと自動化を実現するためのプラグインです。 | 10 | https://t.co/bWvsmYzBLw |
2 | Woldfram | - | - | - | - | - | - |
3 | Zapier | - | - | - | - | - | - |
4 | ChatWithPDF | - | - | - | - | - | - |
5 | SEOapp | - | - | - | - | - | - |
... | ... | ... | ... | ... | ... | ... | ... |
1 | ChatGPT | プラグイン | テクノロジー | チャットボット、プラグイン | ChatGPTは、チャットボットを活用したコミュニケーションを簡単に構築できるサービスです。 | 10 | https://chatgpt.com/ |
2 | Woldfram | プラグイン | テクノロジー | ワークフロー、プラグイン | Woldframは、ワークフローを自動化するためのプラグインサービスです。 | 8 | https://www.woldfram.com/ |
3 | Zapier | プラグイン | テクノロジー | ワークフロー、プラグイン | Zapierは、あらゆるWebサービスを統合するためのプラグインサービスです。 | 8 | https://zapier.com/ |
4 | ChatWithPDF | プラグイン | テクノロジー | チャットボット、PDF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)