const regex = /.+(\r|\n|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+(\\r|\\n|$)', 'gm')
const str = `
1 | ChatGPT | プラグイン | ソフトウェア | チャットボット、自動化 | ChatGPTは、チャットボットと自動化を実現するためのプラグインです。 | 10 | https://t.co/bWvsmYzBLw |
2 | Woldfram | - | - | - | - | - | - |
3 | Zapier | - | - | - | - | - | - |
4 | ChatWithPDF | - | - | - | - | - | - |
5 | SEOapp | - | - | - | - | - | - |
... | ... | ... | ... | ... | ... | ... | ... |
1 | ChatGPT | プラグイン | テクノロジー | チャットボット、プラグイン | ChatGPTは、チャットボットを活用したコミュニケーションを簡単に構築できるサービスです。 | 10 | https://chatgpt.com/ |
2 | Woldfram | プラグイン | テクノロジー | ワークフロー、プラグイン | Woldframは、ワークフローを自動化するためのプラグインサービスです。 | 8 | https://www.woldfram.com/ |
3 | Zapier | プラグイン | テクノロジー | ワークフロー、プラグイン | Zapierは、あらゆるWebサービスを統合するためのプラグインサービスです。 | 8 | https://zapier.com/ |
4 | ChatWithPDF | プラグイン | テクノロジー | チャットボット、PDF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}