import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(\\r|\\n|$)";
final String string = "\n"
+ "1 | ChatGPT | プラグイン | ソフトウェア | チャットボット、自動化 | ChatGPTは、チャットボットと自動化を実現するためのプラグインです。 | 10 | https://t.co/bWvsmYzBLw |\n"
+ "2 | Woldfram | - | - | - | - | - | - |\n"
+ "3 | Zapier | - | - | - | - | - | - |\n"
+ "4 | ChatWithPDF | - | - | - | - | - | - |\n"
+ "5 | SEOapp | - | - | - | - | - | - |\n"
+ "... | ... | ... | ... | ... | ... | ... | ... |\n\n\n\n"
+ "1 | ChatGPT | プラグイン | テクノロジー | チャットボット、プラグイン | ChatGPTは、チャットボットを活用したコミュニケーションを簡単に構築できるサービスです。 | 10 | https://chatgpt.com/ |\n"
+ "2 | Woldfram | プラグイン | テクノロジー | ワークフロー、プラグイン | Woldframは、ワークフローを自動化するためのプラグインサービスです。 | 8 | https://www.woldfram.com/ |\n"
+ "3 | Zapier | プラグイン | テクノロジー | ワークフロー、プラグイン | Zapierは、あらゆるWebサービスを統合するためのプラグインサービスです。 | 8 | https://zapier.com/ |\n"
+ "4 | ChatWithPDF | プラグイン | テクノロジー | チャットボット、PDF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}