use strict;
my $str = '
1 | ChatGPT | プラグイン | ソフトウェア | チャットボット、自動化 | ChatGPTは、チャットボットと自動化を実現するためのプラグインです。 | 10 | https://t.co/bWvsmYzBLw |
2 | Woldfram | - | - | - | - | - | - |
3 | Zapier | - | - | - | - | - | - |
4 | ChatWithPDF | - | - | - | - | - | - |
5 | SEOapp | - | - | - | - | - | - |
... | ... | ... | ... | ... | ... | ... | ... |
1 | ChatGPT | プラグイン | テクノロジー | チャットボット、プラグイン | ChatGPTは、チャットボットを活用したコミュニケーションを簡単に構築できるサービスです。 | 10 | https://chatgpt.com/ |
2 | Woldfram | プラグイン | テクノロジー | ワークフロー、プラグイン | Woldframは、ワークフローを自動化するためのプラグインサービスです。 | 8 | https://www.woldfram.com/ |
3 | Zapier | プラグイン | テクノロジー | ワークフロー、プラグイン | Zapierは、あらゆるWebサービスを統合するためのプラグインサービスです。 | 8 | https://zapier.com/ |
4 | ChatWithPDF | プラグイン | テクノロジー | チャットボット、PDF';
my $regex = qr/.+(\r|\n|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}