// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\/(dhtml\/)?(home\.php\?id=([0-9]+)|page-.*-([0-9]+)\.html)").unwrap();
let string = "/dhtml/home.php?id=10040
/page-bateaux-electriques-kyosho-10040.html
/dhtml/page-bateaux-electriques-kyosho-10040.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}