import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(dhtml\\/)?(home\\.php\\?id=([0-9]+)|page-.*-([0-9]+)\\.html)";
final String string = "/dhtml/home.php?id=10040\n"
+ "/page-bateaux-electriques-kyosho-10040.html\n"
+ "/dhtml/page-bateaux-electriques-kyosho-10040.html";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}