$re = '/^\/(dhtml\/)?(home\.php\?id=([0-9]+)|page-.*-([0-9]+)\.html)/';
$str = '/dhtml/home.php?id=10040
/page-bateaux-electriques-kyosho-10040.html
/dhtml/page-bateaux-electriques-kyosho-10040.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);