#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\/(dhtml\/)?(home\.php\?id=([0-9]+)|page-.*-([0-9]+)\.html)"
Local $sString = "/dhtml/home.php?id=10040" & @CRLF & _
"/page-bateaux-electriques-kyosho-10040.html" & @CRLF & _
"/dhtml/page-bateaux-electriques-kyosho-10040.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")