# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^reflectance_\d_)(\S*)$"
test_str = ("reflectance_7_myd21a1_emissivity_29\n"
"reflectance_7_myd21a1_emissivity_29_savitzkygolay\n"
"reflectance_7_myd21a1_emissivity_31\n"
"reflectance_7_myd21a1_emissivity_31_savitzkygolay\n"
"reflectance_3_myd21a1_emissivity_32\n"
"reflectance_2_myd21a1_emissivity_32_savitzkygolay\n"
"reflectance_1_mcd43a3_albedo_bsa_band1\n"
"reflectance_3_mcd43a3_albedo_bsa_band2\n"
"reflectance_7_mcd43a3_albedo_bsa_nir\n"
"reflectance_7_mcd43a3_albedo_bsa_shortwave\n"
"reflectance_7_mcd43a3_albedo_bsa_vis\n"
"reflectance_7_mcd43a3_albedo_wsa_band1\n"
"reflectance_7_mcd43a3_albedo_wsa_band2\n"
"reflectance_7_mcd43a3_albedo_wsa_nir\n"
"reflectance_7_mcd43a3_albedo_wsa_shortwave\n"
"reflectance_7_mcd43a3_albedo_wsa_vis")
subst = "($1)vs_$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.