import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^reflectance_\\d_)(\\S*)$";
final String string = "reflectance_7_myd21a1_emissivity_29\n"
+ "reflectance_7_myd21a1_emissivity_29_savitzkygolay\n"
+ "reflectance_7_myd21a1_emissivity_31\n"
+ "reflectance_7_myd21a1_emissivity_31_savitzkygolay\n"
+ "reflectance_3_myd21a1_emissivity_32\n"
+ "reflectance_2_myd21a1_emissivity_32_savitzkygolay\n"
+ "reflectance_1_mcd43a3_albedo_bsa_band1\n"
+ "reflectance_3_mcd43a3_albedo_bsa_band2\n"
+ "reflectance_7_mcd43a3_albedo_bsa_nir\n"
+ "reflectance_7_mcd43a3_albedo_bsa_shortwave\n"
+ "reflectance_7_mcd43a3_albedo_bsa_vis\n"
+ "reflectance_7_mcd43a3_albedo_wsa_band1\n"
+ "reflectance_7_mcd43a3_albedo_wsa_band2\n"
+ "reflectance_7_mcd43a3_albedo_wsa_nir\n"
+ "reflectance_7_mcd43a3_albedo_wsa_shortwave\n"
+ "reflectance_7_mcd43a3_albedo_wsa_vis";
final String subst = "($1)vs_$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}