re = /^(?:ds1\-uk\-rules\-[1-3]|fh\-uk11)\.mailshell\.net$/mi
str = 'ds1-uk-rules-1.mailshell.net
ds1-uk-rules-2.mailshell.net
ds1-uk-rules-3.mailshell.net
fh-uk11.mailshell.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end