$re = '/^(?:ds1\-uk\-rules\-[1-3]|fh\-uk11)\.mailshell\.net$/mi';
$str = 'ds1-uk-rules-1.mailshell.net
ds1-uk-rules-2.mailshell.net
ds1-uk-rules-3.mailshell.net
fh-uk11.mailshell.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);