using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:ds1\-uk\-rules\-[1-3]|fh\-uk11)\.mailshell\.net$";
string input = @"ds1-uk-rules-1.mailshell.net
ds1-uk-rules-2.mailshell.net
ds1-uk-rules-3.mailshell.net
fh-uk11.mailshell.net";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}