#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:ds1\-uk\-rules\-[1-3]|fh\-uk11)\.mailshell\.net$"
Local $sString = "ds1-uk-rules-1.mailshell.net" & @CRLF & _
"ds1-uk-rules-2.mailshell.net" & @CRLF & _
"ds1-uk-rules-3.mailshell.net" & @CRLF & _
"fh-uk11.mailshell.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")