use strict;
my $str = '1
1-2
1,23,1-4,5,23,123
1,2,3,4,5,6-10
1,123-123,4,1,66,123
1-2,2-3,3-4,4-5,6-7,8,9,10';
my $regex = qr/^(?:(?:\d+(?:-\d+)?),?)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}