import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\d+(?:-\\d+)?),?)+$";
final String string = "1\n"
+ "1-2\n"
+ "1,23,1-4,5,23,123\n"
+ "1,2,3,4,5,6-10\n"
+ "1,123-123,4,1,66,123\n"
+ "1-2,2-3,3-4,4-5,6-7,8,9,10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}