using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:\d+(?:-\d+)?),?)+$";
string input = @"1
1-2
1,23,1-4,5,23,123
1,2,3,4,5,6-10
1,123-123,4,1,66,123
1-2,2-3,3-4,4-5,6-7,8,9,10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}