const regex = /^(?:(?:\d+(?:-\d+)?),?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\d+(?:-\\d+)?),?)+$', 'gm')
const str = `1
1-2
1,23,1-4,5,23,123
1,2,3,4,5,6-10
1,123-123,4,1,66,123
1-2,2-3,3-4,4-5,6-7,8,9,10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}