import Foundation
let pattern = #"(?<=suppl/)(.*(?:pdf|doc|xml))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0040-1719933/suppl/sup_ss-2022-f0205-op_10-1055_s-0040-1719933.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}