using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=suppl/)(.*(?:pdf|doc|xml))";
string input = @"0040-1719933/suppl/sup_ss-2022-f0205-op_10-1055_s-0040-1719933.pdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}