const regex = new RegExp('(?<=suppl/)(.*(?:pdf|doc|xml))', '')
const str = `0040-1719933/suppl/sup_ss-2022-f0205-op_10-1055_s-0040-1719933.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}