$re = '/(?<=suppl/)(.*(?:pdf|doc|xml))/';
$str = '0040-1719933/suppl/sup_ss-2022-f0205-op_10-1055_s-0040-1719933.pdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);