// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}").unwrap();
let string = "5c251366-f548-4aaf-a1cc-3dc3372d1302
c54579ac-1e3c-41ab-a020-1eaf2de425ab
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}