package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}`)
var str = `5c251366-f548-4aaf-a1cc-3dc3372d1302
c54579ac-1e3c-41ab-a020-1eaf2de425ab
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}