const regex = /[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}', 'ig')
const str = `5c251366-f548-4aaf-a1cc-3dc3372d1302
c54579ac-1e3c-41ab-a020-1eaf2de425ab
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}