import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}";
final String string = "5c251366-f548-4aaf-a1cc-3dc3372d1302\n"
+ "c54579ac-1e3c-41ab-a020-1eaf2de425ab\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}