re = /{{\W*((?:(?:[a-zA-Z_]\w+?(?:\[\d+\])?(?:\.[a-zA-Z_])?))+)\W*}}/m
str = '{{ users[0].name }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end