using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{\W*((?:(?:[a-zA-Z_]\w+?(?:\[\d+\])?(?:\.[a-zA-Z_])?))+)\W*}}";
string input = @"{{ users[0].name }}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}