$re = '/{{\W*((?:(?:[a-zA-Z_]\w+?(?:\[\d+\])?(?:\.[a-zA-Z_])?))+)\W*}}/m';
$str = '{{ users[0].name }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);