const regex = /{{\W*((?:(?:[a-zA-Z_]\w+?(?:\[\d+\])?(?:\.[a-zA-Z_])?))+)\W*}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{\\W*((?:(?:[a-zA-Z_]\\w+?(?:\\[\\d+\\])?(?:\\.[a-zA-Z_])?))+)\\W*}}', 'gm')
const str = `{{ users[0].name }}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}