// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\*|\*\/([0-9]|[0-5][0-9])|([0-9]|[0-5][0-9])|([0-9]\-([0-9]|[0-5][0-9])|([0-9]\,([0-9]|[0-5][0-9]))))$").unwrap();
let string = "*
*/5
*/59
5
1-5
1-59
1,5
1,59
*/60
1-60
1,60";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}