#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\*|\*\/([0-9]|[0-5][0-9])|([0-9]|[0-5][0-9])|([0-9]\-([0-9]|[0-5][0-9])|([0-9]\,([0-9]|[0-5][0-9]))))$"
Local $sString = "*" & @CRLF & _
"*/5" & @CRLF & _
"*/59" & @CRLF & _
"5" & @CRLF & _
"1-5" & @CRLF & _
"1-59" & @CRLF & _
"1,5" & @CRLF & _
"1,59" & @CRLF & _
"" & @CRLF & _
"*/60" & @CRLF & _
"1-60" & @CRLF & _
"1,60"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")