re = /^(\*|\*\/([0-9]|[0-5][0-9])|([0-9]|[0-5][0-9])|([0-9]\-([0-9]|[0-5][0-9])|([0-9]\,([0-9]|[0-5][0-9]))))$/m
str = '*
*/5
*/59
5
1-5
1-59
1,5
1,59
*/60
1-60
1,60'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end