import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\*|\\*\\/([0-9]|[0-5][0-9])|([0-9]|[0-5][0-9])|([0-9]\\-([0-9]|[0-5][0-9])|([0-9]\\,([0-9]|[0-5][0-9]))))$";
final String string = "*\n"
+ "*/5\n"
+ "*/59\n"
+ "5\n"
+ "1-5\n"
+ "1-59\n"
+ "1,5\n"
+ "1,59\n\n"
+ "*/60\n"
+ "1-60\n"
+ "1,60";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}