re = /^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/?\n]+)?(\/)?([a-z]{2}-[a-z]{2})/mi
str = 'https://me.sumup.com/de-de/hello
https://me.sumup.com/hello
www.me.sumup.com/de-de/hello
me.sumup.com/br-br/hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end