$re = '/^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/?\n]+)?(\/)?([a-z]{2}-[a-z]{2})/mi';
$str = 'https://me.sumup.com/de-de/hello
https://me.sumup.com/hello
www.me.sumup.com/de-de/hello
me.sumup.com/br-br/hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);