using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/?\n]+)?(\/)?([a-z]{2}-[a-z]{2})";
string input = @"https://me.sumup.com/de-de/hello
https://me.sumup.com/hello
www.me.sumup.com/de-de/hello
me.sumup.com/br-br/hello";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}