const regex = /^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/?\n]+)?(\/)?([a-z]{2}-[a-z]{2})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:[^@\\\/\\n]+@)?(?:www\\.)?([^:\\\/?\\n]+)?(\\\/)?([a-z]{2}-[a-z]{2})', 'gmi')
const str = `https://me.sumup.com/de-de/hello
https://me.sumup.com/hello
www.me.sumup.com/de-de/hello
me.sumup.com/br-br/hello`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}