re = /public (?:.*?) (.*)/
str = 'private float handBrake;
public uint CarFlags
{
get => carFlags;
set
{
if (carFlags == value)
return;
SetProperty(ref carFlags, value);
}
}
public uint CarFlags2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end