import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public (?:.*?) (.*)";
final String string = "private float handBrake;\n\n"
+ "public uint CarFlags \n"
+ " {\n"
+ " get => carFlags;\n\n"
+ " set\n"
+ " {\n"
+ " if (carFlags == value)\n"
+ " return;\n\n"
+ " SetProperty(ref carFlags, value);\n"
+ " }\n"
+ "}\n"
+ "public uint CarFlags2 \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}