package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`public (?:.*?) (.*)`)
var str = `private float handBrake;
public uint CarFlags
{
get => carFlags;
set
{
if (carFlags == value)
return;
SetProperty(ref carFlags, value);
}
}
public uint CarFlags2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}