using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public (?:.*?) (.*)";
string input = @"private float handBrake;
public uint CarFlags
{
get => carFlags;
set
{
if (carFlags == value)
return;
SetProperty(ref carFlags, value);
}
}
public uint CarFlags2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}