re = /^(?i)username=(.+)\nserver_name=(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/
str = 'username=igor_lakhtenkov
server_name=192.168.122.87
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end