import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)username=(.+)\\nserver_name=(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})";
final String string = "username=igor_lakhtenkov\n"
+ "server_name=192.168.122.87\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}