$re = '/^(?i)username=(.+)\nserver_name=(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/';
$str = 'username=igor_lakhtenkov
server_name=192.168.122.87
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);