package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?i)username=(.+)\nserver_name=(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})`)
var str = `username=igor_lakhtenkov
server_name=192.168.122.87
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}